I suggest you ...

Remove Remove + from number of bedrooms

When i want to filter the advts to see only 2BR flats, i am having the results of 2 and more bedrooms due to "+" in the options. I dont feel its a good idea to show 2+ BR flats. Not justifying the filter

2 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Aqueel Mohammed shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base